PayPal errors with Rebel.com accounts
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 14:33 EDT
Identified
For Rebel.com accounts, our team are working to resolve errors processing PayPal payments and adding PayPal in the Payment Settings menu. We expect this may require a few days to resolve. We apologize for any inconvenience.
Posted Mar 15, 2024 - 11:35 EDT