Service Centre Disabled Temporarily
Incident Report for Rebel
Resolved
We can confirm that the issue with our Contact Centre has been resolved. Thank you.
Posted Jul 19, 2021 - 21:26 EDT
Investigating
We are currently investigating an issue with our Customer Management System which is preventing us from accepting customer contacts (phone or email). We are working with our 3rd party provider and will provide an update as soon as the issue is resolved. We apologize for the inconvenience.

Please note that this should not affect the functionality of any systems. Only our ability to handle client calls/emails is affected.
Posted Jul 19, 2021 - 20:28 EDT