Customer Service Disruption
Incident Report for Rebel
Resolved
The impact of power outages on our support team has been resolved. Thank you for your patience.
Posted Apr 07, 2023 - 10:14 EDT
Investigating
Due to power outages, our customer service center is currently experiencing slower-than-usual response times. We apologize for any delays and inconvenience this may have caused.
Posted Apr 06, 2023 - 10:04 EDT