Issues Connecting to Webmail or Accessing Email Via Email Clients (e.g., Outlook)
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 09:00 EDT
Monitoring
We applied a fix approximately 90 minutes ago and service levels gradually improved. We will keep monitoring the situation, but systems appear to be fully operational.
Posted Jul 20, 2021 - 16:20 EDT
Identified
We have identified an issue that was causing intermittent issues accessing emails either via Webmail or via email clients such as Outlook or Mac Mail. We hope to have this issue resolved shortly.
Posted Jul 20, 2021 - 11:41 EDT