Domains Detaching from Hosting Packages - Hosting Access Issues

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 07:44 EST

Investigating

We are currently investigating an issue affecting Web Hosting clients on the Plesk platform. Clients are reporting that domains attached to their hosting packages are detaching themselves, which is disrupting website and email access.

Clients are experiencing errors such as:
- Websites become inaccessible.
- Emails are not sending or receiving.
- Clients cannot access or manage their hosting packages.

Our team is aware of the issue and actively working on a resolution. We will provide updates as we learn more.

---

The Rebel Team
Posted Nov 27, 2025 - 12:19 EST