Customers are unable to connect with support via Voice

Incident Report for Rebel

Monitoring

Please use chat or email support as we try and resolve this issue. We are working hard to get the issue corrected and understand how this impacts each customer in their attempts to get through to support.
Posted Apr 02, 2025 - 16:08 EDT

Identified

The problem is coming from ZD- It has been reported and they are researching the issue.
Posted Apr 01, 2025 - 14:44 EDT

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 14:44 EDT

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 10:09 EDT

Investigating

We have logged an incident with Zendesk. Will update soon.
Posted Apr 01, 2025 - 10:08 EDT