2FA not being received by primary or secondary email on accounts.

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted May 29, 2025 - 14:26 EDT

Identified

We have identified an issue with 2FA not sending to customers primary or secondary emails on account. 2FA is being received by text. We are looking into this issue and will have an update soon.
Posted May 29, 2025 - 12:48 EDT