Investigating Intermittent DNS Resolution Issues

Incident Report for Rebel

Resolved

The intermittent DNS resolution delays affecting our parked nameservers (dns.rebel.ca and dns2.rebel.ca) have subsided, and performance has returned to normal levels.

Our System Administrators have stabilized the current traffic spike and are continuing to monitor the environment closely. A permanent infrastructure fix is scheduled for deployment later this week to prevent future occurrences.

We thank you for your patience while we worked to resolve this performance issue.
Posted Mar 02, 2026 - 14:58 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 10:14 EST

Identified

We are currently investigating reports of intermittent resolution delays and slow performance affecting domains utilizing our default parked nameservers (dns.rebel.ca and dns2.rebel.ca).

Our System Administrators are actively working on a resolution to stabilize performance. Visitors to affected domains may experience intermittent connection timeouts or slow loading speeds during this time.

We apologize for the inconvenience and will provide further updates as they become available.
Posted Mar 02, 2026 - 09:20 EST