New Domains Purchase - Checkout Issue

Incident Report for Rebel

Resolved

Resolved: July 21, 2025

Some clients recently experienced issues completing new domain purchases through the Rebel.com shopping cart. This affected a small number of transactions where the checkout would stall or the domain remained in the cart without completing the purchase.

We’ve implemented an update to our domain fraud protection system, and the issue should now be fully resolved.

If you continue to experience trouble completing a domain purchase, please don’t hesitate to contact our support team — we’re happy to assist you directly while we monitor for any remaining edge cases.

Thank you for your patience!

— The Rebel.com Team 💜
Posted Jul 21, 2025 - 13:30 EDT

Monitoring

We’ve identified that some clients experienced intermittent issues completing domain purchases due to additional security and payment verification checks implemented to protect accounts.

Manual orders processed by our support team are not affected, and we’re actively working to improve the checkout experience to minimize disruption.

If you experience any issues completing a domain registration, please contact our support team for assistance.

Thank you for your patience and understanding.

– Rebel Support
Posted Jul 18, 2025 - 16:40 EDT

Investigating

Impact:
Some customers are experiencing issues purchasing or renewing domains through the self-service cart interface. Orders processed manually by support are not affected.

Status:
Investigating

Description:
We have identified a problem where clients are unable to complete new domain purchases using their cart on the client portal. This affects the self-service functionality. Our team is actively investigating the root cause and working toward a resolution.

Next Update:
We will provide an update within the next 2 hours or as soon as more information is available.
Posted Jul 18, 2025 - 12:55 EDT