Domain Search feature temporarily offline due to update

Incident Report for Rebel

Resolved

The update is now live.
Posted Apr 01, 2025 - 15:55 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 01, 2025 - 14:46 EDT

Identified

We are in the process of a program update. The search feature should be back online shortly.
Posted Apr 01, 2025 - 14:46 EDT