Investigating an issue with our chat support
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 14:36 EST
Investigating
Our team are currently investigating an issue with our chat support. We hope to have this resolved in the near future. We apologize for any inconvenience.
Posted Feb 08, 2024 - 09:56 EST