2FA code delayed delivery

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 14:21 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2025 - 12:26 EDT

Identified

We have identified an issue where the 2FA code is delayed in delivery to the email address of record. We are working to rectify ASAP.
Posted Jun 11, 2025 - 12:26 EDT