Customers reporting Phishing emails appeared to be from Rebel.com

Incident Report for Rebel

Update

Posted Nov 17, 2025 - 10:13 EST

Update

Do not click on any link in the email.
Posted Nov 17, 2025 - 08:47 EST

Monitoring

We’re aware of fraudulent emails circulating that pretend to be Rebel renewal notices. These messages are not from us. Your accounts are safe, and our team is monitoring the situation.

Please manage renewals by signing in directly. If you receive a suspicious email, avoid clicking links and check your account or contact our team.

Please report this to abuse@mailgun.org

⚠️ Urgent: Renew Your Rebel Service

Dear Customer,

Your Rebel service will expire very soon — renew now to avoid disruption.

Immediate action required: Please renew now to avoid service disruption.
Once expired, access to your email, hosting, or domain may be affected.

Renew Now

If your renewal has already been processed, no further action is needed.

Thank you for your prompt attention.
The Rebel.com Team

© 2025 Rebel.com Internet Solutions Pte Ltd
Terms of Service | Privacy Policy | Contact Support



This email has not been sent by Rebel.
Posted Nov 17, 2025 - 08:37 EST