Account interface response issues

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 15:06 EST

Investigating

Our team are investigating account interface response issues impacting our staff-side and client-side navigation. This matter is being investigated with urgent priority.
Posted Feb 10, 2025 - 11:46 EST