Errors during payments and credit card update attempts
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 16:03 EDT
Monitoring
Our team have implemented a fix and we are seeing successful credit card transactions. Thank you.
Posted Jul 24, 2023 - 14:49 EDT
Investigating
Our team are seeing errors during payments and credit card update attempts, we are currently investigating and hope to have this resolved soon. We apologize for any inconvenience.
Thank you.
Posted Jul 24, 2023 - 10:56 EDT