Live Service Queues Closed from 1:00PM - 3:00PM (Eastern)
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Feb 24, 2021 - 17:30 EST
Identified
Please note that our live service queues will be closed for a company-wide meeting. We apologize for the inconvenience.
Posted Feb 24, 2021 - 13:04 EST