Mail Delivery Issue (SSL) and Identities

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 15:03 EDT

Monitoring

We have identified an issue with Canada16 server that has reportedly created an issue with sending Emails. We are quickly working to correct the issue. Secondary issue- Identities not showing/ pre-populating when you create an email. This is also being addressed.
Posted Jun 23, 2025 - 16:14 EDT