Account Navigation Issues
Incident Report for Rebel
Resolved
This incident was resolved.
Posted May 26, 2023 - 12:38 EDT
Monitoring
Thank you for your patience.

Our team have resolved the account response issue.

We apologize for any inconvenience.
Posted May 24, 2023 - 11:36 EDT
Investigating
We are currently experiencing an issue that is causing customers to experience timeouts/error pages while navigating their Rebel accounts. Our developers are aware of the issue and are working to resolve it as soon as possible, Unfortunately, this issue also affects our Customer Service team's ability to assist you. We apologize for the inconvenience. Please note that this issue should not have a negative impact on customer site functionality.
Posted May 23, 2023 - 15:56 EDT