We are updating the messaging on our phone lines- adding a callback feature.

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 15:03 EDT

Identified

WE are in the process of updating our IVR phone system. Customers will have the option to request a callback versus sitting on hold. The option will be enabled as a secondary menu feature. Please press 0 to get to an agent. In that menu, you will have the option to Press 2 to request a callback. They system will then ask to verify the number you wish to received the call back on. Do not hang up until you have ensured the number is the one you wish to use for a call back. This change will begin at 11:00 AM EST June 23rd
Posted Jun 23, 2025 - 10:30 EDT