Chat Service Temporarily Unavailable
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 08:31 EST
Identified
We are currently investigating an issue with our live chat program, which is preventing us from assisting customers. We ask that you email us at service@rebel.com while we work to address the issue with our service provider. We apologize for the inconvenience.
Posted Dec 18, 2023 - 17:51 EST