Investigating slow website response for some Plesk servers
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Oct 31, 2024 - 15:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2024 - 08:26 EDT
Investigating
Our team are investigating slow website response related to some Plesk servers.
canada3.rebel.com, canada4-mw.rebel.com, canada7.rebel.com

We will follow with updates.
Thank you.
Posted Oct 29, 2024 - 12:50 EDT