Plesk canada7.rebel.com server issue
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 13:19 EDT
Monitoring
Plesk canada7.rebel.com is operational now.
Posted Mar 15, 2024 - 11:51 EDT
Investigating
Our team are investigating an issue with Plesk canada7.rebel.com. We hope to have this resolved in the near future. We apologize for any inconvenience.
Posted Mar 15, 2024 - 10:09 EDT