Audio issues with phone support
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 14:35 EDT
Update
The phone audio issue has been resolved.
Posted Apr 22, 2024 - 14:34 EDT
Investigating
Our team are currently experiencing some audio issues with phone support. We hope to have this resolved in the near future. Our chat and email support are functioning normally.
Posted Apr 22, 2024 - 10:42 EDT