Current high customer contact is creating an issue with call routing. .

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 14:53 EDT

Investigating

We are currently investigating the issue. In the interim please contact us via chat or email.
Posted Nov 04, 2024 - 13:08 EST