Rebel Cloud Email IMAP/Webmail Performance & Access Issues

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 17:08 EDT

Update

We are continuing to investigate this issue.
Posted Oct 12, 2025 - 14:12 EDT

Investigating

Investigating - We are currently investigating an issue affecting Cloud Email services for some clients. Users have reported errors such as:

Webmail: “IMAP server refuses to import one or more emails” and “Failed to load messages”
General: Delays in receiving new emails and slow performance on the webmail portal
Additional symptoms: Inability to delete messages from inbox

Our team is actively looking into the issue and working to identify the root cause. We will provide further updates as soon as more information becomes available.

Thank you.
Posted Oct 11, 2025 - 15:53 EDT