NEW Domain Renewal System Unavailable

Incident Report for Rebel

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 09:17 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 09:20 EST

Investigating

We are experiencing a critical technical issue affecting the domain renewal process. Currently, the "Renew Domain" function in the Domain Manager is failing to populate the shopping cart, resulting in an "Order is empty" error.

Our engineers are treating this as a top-priority incident. Please be advised that our support agents are currently seeing the same error and cannot process renewals manually at this time. If your domain is nearing its expiration date, please do not worry; we are tracking all pending renewals and will ensure no domains are lost due to this system outage.

We will provide an update as soon as the checkout bridge is restored.
Posted Feb 20, 2026 - 13:13 EST