Payment Processing and Credit Card Update Errors - Rebel.ca
Incident Report for Rebel
Resolved
Our Payment Processor reports that the issue has been corrected. We have not seen any recurrences of the issue. We are marking this issue as resolved.
Posted May 11, 2022 - 10:01 EDT
Investigating
We have received reports of errors occurring when credit card updates and transactions are being attempted. We are working with our Payment Processor to resolve the issue as soon as possible. We thank you for your patience.
Posted May 10, 2022 - 12:28 EDT