Intermittent Rebel Site Slow Downs
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 16:53 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2021 - 11:26 EST
Investigating
We are currently investigating an issue with intermittent site slow downs which can cause problems with processes such as logging into accounts, adding credit cards and processing payments. We will have more information shortly.
Posted Nov 19, 2021 - 10:28 EST