Service Centre Disruption
Incident Report for Rebel
Resolved
This incident has been resolved.
Posted May 21, 2022 - 22:25 EDT
Investigating
Please note that our service centre is currently offline due to power outages caused by severe thunderstorms. We hope to be back online shortly.

Important: no other services should be affected by this outage. Only our Customer Service team's ability to handle live interactions is affected. You can still email questions to service@rebel.com
Posted May 21, 2022 - 16:32 EDT