Some Cloud Email clients obtaining error "Cannot Verify Server Identity - imap.rebel.com"
Incident Report for Rebel
Resolved
The SSL cert was updated a few days ago. The install may have caused a few users to experience the error where imap.rebel.com could not be verified as there was no certificate present for a short time.
Our team have confirmed that the certificate that is in place today is valid until next year. Please note that some users may need to install any outstanding operating system updates on their devices for the certificate to show as trusted.
Posted Apr 05, 2024 - 11:48 EDT
Investigating
Some Cloud Email clients obtaining error "Cannot Verify Server Identity - imap.rebel.com". Our team are investigating and we hope to have an update in the near future.
Posted Apr 05, 2024 - 09:50 EDT